Issues with my new Chinese Android 2.2 tablet


Jan 10, 2011
Ordered my Android 2.2 OS Tablet 8 Inch with Freescale iMX515 Cortex A8 Chip, support Flash Player 10,512M RAM from NowSupplier on 1/10/2011. I paid for UPS shipping and after a short delay it was shipped via DHL. For some unknown reason the package was returned to NowSupplier by DHL and they re-shipped using UPS. Received my tablet 1/24. Have been playing with it for a few days now. Seems like a great buy. It meets all the listed specs and even came with the official Market already installed along with another "market" type app.

So far the only issue I see is that my 8gb SD card reads as a 3gb card and the screen will not go to sleep, it only dims no matter which setting I have the display on. I installed a couple of different screen lock apps and they seem to shut the screen down but when I press a button to wake it up I just get a complete white screen, I have to hit the reset button to restart the tablet. Anybody else have this issue on a tablet?


Dec 27, 2010
I have returned two of them, it cost 20 each to send back to Nowsupplier, mine and my sons both worked perfectly a few days, then on the same day both went nuts, they wouldn't load past the Penquin in upper left screen, although we never touch it , Touchscreen calibration window came on every time we started it and when we used a stylus or finger and the points would exit, but it would not go any further, we reset , we tried everything, nothing helped however luckily ,they have 10 day money back & 30 day return policy also paypal will reverse the purchase price in the 1st 45 day period,

We just went on and got 2 new Elocity A7 pad with Tegra duo core processor, more memory, more ram, bluetooth, Android 2.2 with 10.1 flash, multi touch screen update, 6 payments on debit card 49.95, no interest 7.99 shipping, can be updated no problemto Android 3.0 due to processor speed and extra ram , when it comes out soon. Good luck with yours,
Last edited:


Mar 7, 2011
Seems I've got a similar issue.
I recently purchased the Android 2.2 tablet MHK802 made by Cupor Digital.
The first day it worked fine.
The second day it is getting stuck at the screen “Touchscreen Calibration” I touch the screen when the + appears and then the screen fades away to be black?
I have used the master reset a few times but the same problem keeps persisting.