Kocaso m1070 Tablet Battery Problem


May 24, 2013
Hello, thank you for visiting my post, and trying to help!

I have a Kocaso m1070 Tablet i'm trying to fix. It has the RK3066 Rockchip. The tablet is used in my car as an entertainment center for music and movies etc. It works great when it works :p I bought this tablet for $50 from a co-worker. The battery shows 100% charged, but doesn't work. I was satisfied with that until the power plug started being picky. Something is a bit lose, so when I hit a hard bump the tablet shuts off, or I have to position the power plug a certain way and not move the tablet.

I've read a lot of posts for other tablets having similar battery issues, but I'm afraid those readings were not specific to this tablet. The more common issue I read about is the battery showing 1%, and it's not charging at all. Mine strangely shows 100% charged, and never shows anything less than that.

I've removed the back-plate, and I inspected the PCB. I don't see any visual damage.

One last explanation I feel is critical. The Tablet actually tried to turn on with the battery when I first received it, but their was not enough juice in the battery left to boot the tablet. The co-worker did not include the charger, and tried to say it charges with the usb cable, so I left the usb cable plugged in overnight. I noticed the tablet was turning on and off, and it may have done this all night. When I checked it in the morning, it was showing vertical white lines from top to bottom on half of the screen. I believe this completely discharged the battery because it will not do anything at all when I push the power button while unplugged.

The charger I picked up was from Radio Shack soon after this event. It's power output matches the exact specification of the tablet. (2 amps/5v) I still cannot get the battery to work though. I'd really like to fix that.
Last edited:


Hello mate

I think you should have Search the web before you bought it from you mate, at 50$ you can't buy batteries for tablets