Kyros 7015 frozen at 'Coby' screen...bricked or not?


Sep 20, 2012
Good afternoon all,

I attempted to boot up my Kyros and ugrade the rom yesterday, but upon reboot it freezes at the 'Coby' screen. No combination of keys that I've tried can change this with the exception of the rear reset button, which only boots back to the 'Coby' logo. The only way it shuts off is when the battery dies. My PC recognizes that the device is connected, as both internal and external SD cards show up on 'my computer', but I'm unable to access either one of them. I've looked all over for a solution, and I cannot find anything that works. I've tried the 'get out of fastboot' method, but when I attempted to install the 'Android Platform Sooner Single ADB interface', I get a 'code 10' error in the device manager next to the interface. Apparently the driver isn't compatible with Windows 7 so I'm unable to proceed any further in that respect.

I've had problems since the day I got this tablet (initially with the god-awful Android 2.1-that's why I wanted to upgrade it), and I'm at the point of tossing it in the trash. I'm not 100% sure that it's bricked, but since the only way I can access the external SD is to remove it to my PC, it might as well be. Please...any assistance you can provide would be much appreciated...Thanks! :)