Lenovo S6000 Fastboot Unlock Issues


Junior Member
Jun 26, 2015
Like many of you, my S6000F was easily rooted; but, isn't cooperating with my attempts to unlock it.
I have been following the directions posted at Lenovo Ideatab S6000 Unlock Bootloader Tutorial (not allowed to post a link here); but, have hit a brick wall when trying to execute the command line: fastboot-windows oem unlock

I get one of two error messages:
1) If I am at the command line, and the tablet is in normal Android, it will say: Waiting on device
2) If I have the tablet in fastboot mode, it will say: fastboot is not recognized as an external or internal command

I have ensured that
  • ADT was fully installed and configured
  • the correct adb windows and adb drivers were installed (I have tried the Google drivers provided with the guide I lined to above; and, also tried the Universal Naked Drivers)
  • adb can 'see' the tablet, as can Windows (in device manager with the tablet in normal and fastboot modes)
  • I use an administrative command prompt window
  • adb, fastboot and sdk are all in the same folder; and, that I open an administrative command prompt in that same folder
I have honestly spent hours trying to find relevent info via Google and Bing; and, then researching in the forums that show up in the searches. All the steps that I bulleted above are the results of what I have found, piecemeal; but, I havn't been able to find one, complete lucid guide to this issue. Any solid direction would be greatly appreciated.

Thanks, in advance!
PJ Arts