Locked out of 7127


Feb 8, 2012
Our 7 year old wanted to be like her older sister and had her put a pattern lock on her 7127, course she forgot it the very next time and got locked out after too many attempts. It now wants a google account logon to unlock it, we have tried all our accounts and none work. We have no idea who was signed in before, her brother, friends grandpa, cousins ? We will probably never find out.

First, is there a simple way just to wipe the tablet back to default, nothing important is on it and we just can just redownload everything else. Ive tried holding the reset button for more then 10 seconds but it didnt do anything but reboot it. There was no backup software installed on it and the rest was pretty much all factory defaults, never turned on usb debugging. Only thing I did was install android market.

Next, Ive tried things like fastboot and downloaded the factory rom that someone posted hoping to reflash it, but it can never connect to the device when I enter fastboot mode. I tried the usb driver in the android sdk but it says not compatible. Where can I find a driver that will work ?

I can still turn on mass storage and access the files & folders, can I delete/replace files to clear the saved passwords or copy them from my phone (that I know the google account logon for) ?


Senior Member
Jul 4, 2011
to figure out what account is associated with the device open up accounts.db in /data/system. This is the file you delete to remove the account from your tablet however in your case I do not think deleting it would remove the passlock I am not sure though


Senior Member
Nov 8, 2011
You should be able to boot into recovery and do a factory reset that should delete all data, it will return your table to like new, out of the box status.