My google android tablet 2.2 Will Not help help


Nov 17, 2011
i just brought a tablet off amazon and it just arrived to my house today. the only thing i did was install a universal android apk. but it didnt root my device. then i held the power button and vol+ and tried to go to the root screen but it just kept blanking out. i left it alone for about 15 minutes and it never started back up. when it is plugged up into the wall the red light shows but it doesnt show a sign of powering on at all. i held the button for 5 minutes but nothing. tried all of the power and vol+, power and menu, power and home, and power and vol-. keep in mind i just bought it and it just arrived at my house. i played with it for about 30 mins then it just quit on me.

do any one have any tips that i can try to make it work. it is currently plugged up into the wall charging over night.

hhhhhhhhhhhhhhheeeeeeeeeeeeeeelllllllllllllllpppppppppppppppppppp please...................


just send it back and get my money back


Staff member
Sep 24, 2010
We can try to help, but we need more info. What kind of tablet specifically is it? Android 2.2 is way to generic a name. Please tell us any info you may have, is there any vendor info on the box, etc. It sounds like you may have put the tablet in recovery mode, which may look like a blank screen.


Nov 3, 2011
Just send it back asap that is less of a problem right now.

Sent from my IDEOS S7 Slim using Tapatalk