New Flytouch 2 perfect for the tinkerer...


Jan 25, 2011
The last order of tablets we received worked GREAT except for one. It only worked when plugged in. I figured that there was a loose connection and thought that I'd open it up to check it out. I was right about the loose connection. The port where the battery plugs into the motherboard had a loose solder. It works on battery power if you press down on the motherboard in that spot. A quick solder will make the connection permanent.

I did have an issue when I pulled the screen off though. I pulled out the little 4 strand ribbon cable from the motherboard. It looks as if it is removable, but I can't get it working again. The ribbon is still attached to the screen, but I can't get it to stay put on the board. I figured I could either keep tinkering around with it and get it going or sell it below cost and give someone a great deal!

It is NOT bricked. I flashed the 1170 firmware on it with no problem. I can flash any firmware you request on it before I ship it, so let me know. It boots up fine and gets to the screen to calibrate but doesn't sense the stylus. This would be great for someone with a bricked tablet. Just replace the guts and you are good to go. The GPS module is in there and I have verified that it works too.

Price is $165 including shipping within the US!

Update: Last night I broke out the soldering iron and was able to solder the battery connections to the motherboard pretty easily. I had to expose more of the copper at the end of touch screen ribbon to get it to seat properly in the slot. EVERYTHING is working properly now, but I can sell the tablet as new so it is still at a severely discounted price!
Last edited:


Dec 12, 2010
He fixed it, it's better than new. You didn't read the whole message. I just bought a SuperPad " powered by WowPad" and everything works out of the box, including Market.