Phone Calls ON Tmobile Galaxy Works


Oct 13, 2010
it was confirmed on another sight that it works just wait on the how to

Adventures in trying to get Phone calls - Page 4 - xda-developers

Well, most of the info came from;
post 23.

I just started from a different version as I wasn't able to dial the keypad to find out what I currently had installed.

I'm still not sure if the phone.apk's would have worked, think I was doing it wrong, but many thanks to people who posted theirs. If that does work, it'd be far easier and less 'omg I think I've just trashed it' moments.

After a few moments of the Android restore shell, the download screen, and the 'phone-!-computer' screen (which as it turns out isn't anything to worry about, you can still connect up using odin to flash).

Download Odin3 v1.70
do some googling for;
for the base rom.
for formating. Selected 'Repartition' 'AutoReboot' 'fResetTime'. That rebooted with nothing.
Then, unchecked the 'repartion' part (as the structure is setup, don't want to screw it up, the next flashing needs to 'drop in' where the structure is.

Then, loading into the JHA.rar, flashed that and rebooted.
After some power off/on/off/on again, it's back to being usuable (previous to this, all my other attempts were locking it up at various screens).
The Phone icon WAS visible, but unable to make phone calls.

Now... I was a bit rash here, I also flashed P1000OXAJK1.tar (Repartion set to OFF!) to upgrade, AND I swapped sims to my known working Sim card.

At this point, it rebooted, showed 'Emergency Calls only'
Went into the wireless/Mobile Settings/NetworkOperators and made sure it was connected to TMobile. That that point, I made my first call and it worked.
Received a call too, also working.

Everything else 'appears' to be working apart from the browsing which looks like some APN setting. Every page I'm trying to access takes me to the Tmobile site. I need to set something/have something set I guess. The settings /look/ right, but can't get to non-tmobile if I'm not using wireless.

Though it also looks like I'm not getting much signal too. 1 bar tops (sure I was getting 3 before flashing) so guess there's some issues with the radio. Don't know what todo about that. Not showing the '3', just 'e' when I'm connecting up too. (-107dBm, 3asu, network type : edge)

The settings/about shows 'phone' information, not 'tablet' information as it did before too.

Overall though, it's working ok. Once I get the 3g browsing sorted, it'll be perfect.
Last edited: