Please help me to ID my tablet


Jan 6, 2011
Hi all,

I just bought a tablet (first in my life, that's why i was looking for something cheap).
Everything would be fine, only if i had root :( Cant do anything and i need gprs working on my huawei E160 modem (which almost works but almost... i need to do some changes in files and i done have permissions).

So, here is my tablet:

Photo of the BOX:

1. 8" screen
2. Device Info:

Uploaded with

Memory Size: 256MB
Model Number: generic
Firmware Version: 1.6
Kernel Version: 2.6.29-00236-g4f8dbbb-dirty
Build Number: WMT2.1.2_8102

2. Ports:

Uploaded with

From the left:
- Speaker
- DV IN (9Volts)
- Headphones
- Main port (EThernet/usb adapter)
- MicroSD
- Mini USB
- Speaker

3. /proc/cpuinfo

Uploaded with

Processor: ARM926EJ-S Rev. 5 (v51)
BogoMIPS: 174.48
Features: swp half thumb fastmult edsp java
CPU Implementer: 0x41
CPU Architecture: 5TEJ
CPU Variant: 0x0
CPU Part: 0x926
CPU Revision: 5

hardware: WMT

4. It has a camera...

Please help me with this, i need root (and of cource would be nice have market access).

5. Data from ANdroid System INformation:
- OS: Browser UA: Mozilla/5.0 (linux; U; Android 1.6; en-gb; generic Build/Donut). AppleWebKit/528.5+ (KHTML, like Gecko) Version/3.1.2 Mobile Safari/525.20.1

Build Infos:
Android Version: 1.6
Release Codename: REL
CPU ABI: armeabi
Manufacturer: unknown ;-)
Board: unknown ;-)
Brand: generic
Device: generic
Display: Donut.eng.howayhuo.20101108.164929
Fingerprint: generic/generic/generic/:1.6/Donut/eng.huowayhuo.20101108.164929:user/test-keys
Host: szmce12
ID: Donut
Model: generic
Product: generic
Tags: test-keys
Type: user
User: howayhuo

Download Cache Max: 99,98MB/Free: 97.73MB
Data Max: 618MB/Free: 521MB
Total Ram: 229MB
Free RAM: 134MB
Threshold RAM: 16.00MB

Is there any other information what could help ?
Last edited:


Staff member
Sep 24, 2010
While I can't specifically ID your tablet, I did want to take a moment to commend you! You are the first person I have seen that has started out with full detail in the request. Usually all we see is a post saying something like, "I have a tablet that say 1.6 with a 10" screen. What is it?"

I am sure with everything provided you should get an answer quickly!


Jan 6, 2011
Thank's a lot. I didnt know where to put my post, i'm not even sure if its VIA based tablet, but as far as i know almost all of cheap tablet are based on VIA so i made my decision ;)
I hope someone will help me to find out which rom fit to my tablet.
BTW: would be nice to have back-up of original rom, is it possible some how ?


Super Moderator
Staff member
Aug 6, 2010
This is one of the many low power VIA 8505 WMT Tablets. These are the bottom rung of a tablet. It is running Android Donut V1.6 and the Firmware build of 2.1.2.... More detail can be found under the VIA subsection.
This device is fine as an e-reader, simple web browsing, and limited mult-media capability. You can do MP3s fine but you will be limited to specific video codecs. I cannot tell you which as it varies from manufacturer firmware cook. Use a transcoder such as mediacoder to convert to a usable format.
You can root and get full backups using apps like Titanium Backup. More detail would be found in the VIA group.
There are some devices running the VIA 8505 able to upgrade to Android EClair, but cannot tell you if yours can. Search on TipStir posts. His posts will provide insight and some community builds which might work. Read and research. The details I provided hopefully will be of assistance.


Jan 6, 2011
Wait a minute... so You re saying that there is no reason to change firmware, i can root it via Titanium Backup and same software allow me to do backup of my firmware, settings etc. ?
I know it's poor hardware, but i need it to work, i'm linux administrator so i need ConnectBOT and 3g/wifi, Bluetooth keyboard and that would be really great !

No I was wrong... Titanium Backup didnt rooted my device, it says "please verify that your ROM is rooted"
So there is still problem - i need rooted rom :(
Last edited:


Jan 6, 2011
Well.... It's not so easy...
The device is not Flytouch and not Eken M003.
I tried almost every possible firmware. All firmwares made for M003 are uploading successfull but system is not starting (it hangs while loading with android logo).
So... I suppose it's some new thing because of premade firmware WMT2.1.2_8102 which was there at the beginning. So... I have tried to flash with WMT2.1.2_* but it says UDisk Not find (/dev/sda)
Is this possible, that the device is some mix ? How come that M003 is flashing (i think it's using /dev/mtd as device) and software named WMT2.1.2_* is crashing ?