Ployer MOMO8 Probably Bricked. Help much needed!


May 26, 2012
Please, help! I'm in a desperate situation!

My MOMO8 tablet probably got hard-bricked as I figured it out from the symptoms. The screen won't turn at all, but when I push the power button the tablet gets heated a little. When I turn it off, the heat is gone.

Some background info:
- When I received my tablet it was Android 2.3. I upgraded it to ICS 4.0.1 first, then to 4.0.3
- I installed CWM Recovery for Ainol Novo9. It seems compatible. Made backups and recoveries a couple of times.
- The tablet would restart a few times while playing games. But it wasn't often.
- The last malfunction with this tablet I remember: I was copying a big file (about 300 MB) to the internal sdcard from my PC. The copy speed was about 400 kbytes/s. I cancelled it. Copied the file to external sdcard. Using ES File Explorer I began copying the file from ext sdcard to int sdcard. The copying process was extremely slow. So I decided to cancel it and force-shut the tab down. After that the tab wouldn't start.

After reading many forum pages on the similar problem I have understood that the NAND chip is most likely out of order. There's no internal sdcard that can be found on the board. I double checked it thoroughly. I found the following guide about how to revive a tablet. I can follow and try these steps but it's a different tablet and a different firmware is provided, so I'm at a loss now.

The following questions arise regarding that guide:
Is this the only workable method in my case?
Should I try this method?
If yes, should I use the firmware provided (for HeroTab C8/Dropad A) as the first step to revive my tablet?
How can I convert my stock firmware (*.img format) or a backup made with CWM Recovery into the kind of firmware mentioned above?
Any other suggestions?

I will greatly appreciate any help here.

MAJOR UPDATE -> Tablet Unbricked!!! :cool:

Since there was no way for me to install the stock firmware via LiveSuit, as much as I remember, pressing and holding Vol + and inserting
USB cable did nothing for my computer to react to this, I decided to follow this guide.

I resolved my issue by doing the following:

I used the guide above and covered all the steps.
I shorted the pins 7 & 8 (image below) according to this post:
"What this does is make it look like there is no NAND to the processor, so it doesn't try to boot from it, and looks for the bootloader on the external SD."
In my case, the booting from external SD didn't work. The resolution of the issue came after KillerKink advised that I should
flash the firmware the usual way - via LiveSuit. Thanks to him for guiding me in the right direction! I didn't even figure out that I should have done it.

Bottomline and Recommendation.

Don't do anything with your tablet if you're unsure of what your're doing. Don't reproduce my experience if you're not willing to take the risk!

First perform the steps 1 and 3. If it doesn't help, follow step 2.
If you have a bricked Ployer MOMO (assuming nothing works: no charging indicator, no recovery menu, no lit screen, etc...).
Before fixing it with my method make sure the following conditions are met. Don't follow the guide's instruction specifically for the external SD card. But you may try it.
1. First, make sure the tablet is switched off - feel the back of the tablet with your palm. If it's warm, press Power button for 10 seconds and turn it off.
NOTE! This is risky stuff. Don't take the risk if you're not sure.
Open the turned off tablet, find the NAND chip, short the pins. It means you should connect the two pins with a screwdriver or something, and while the pins are being shorted, turn the tablet on by pressing Menu + Power. At this point the tablet should turn on with a white screen and the pins disconnected immediately. However, the screen wouldn't turn on in my case. Having no success I shorted the pins again (turned off the tablet first) and now pressed only Power. I can't tell it made a difference.

3. Now I have to assume that shorting the pins did something to the hardware and it's now recognized by PC. Use LiveSuit to flash firmware (Press & hold Vol +, connect USB -> Press Power 10 times quickly -> Livesuit notification pops up -> release Vol + and follow instructions). It WORKED! Thanks to Killerkink for encouraging me to use Livesuit at this point.

I will be glad to answer questions related to the topic.

Last edited:


Senior Member
Mar 16, 2011
Actually, I am not sure if you really need to short the pin. To activate livesuit, you need to hold down one of your buttons(in your case vol+, in my case, its the home button) and continuous press the power key. Sometimes, it can take a few try to get it as there is no indication on the screen.


Jul 4, 2012
hi please help,
i have my 8inch chinese tablet bricked, i kinda played around with the build.prop thing and now its stuck on bootloop. my tablet is the same with momo8A but its not, it's cdrking fastpad 8 inches FP-002-xon, but since it looks the same inside and out with the momo8 like in the picture armsagitta posted i tried his instructions... but no success... i also tried killerkinks but all i get is the .img files not
available like iin the picture$untitled.JPG i dont know what to do now... please help
i have installed the driver from the instruction and tool from livesuit from momo website and this is whats installed in the pc
is there something i did wrong in installation? and also will the momo8a firmware work on my tablet? considering they have the same architecture inside?

thanks in advance i will really appreciate it....


May 26, 2012
If you have the native firmware for your Fastpad tablet, use it. I can't tell for sure if the MOMO8A firmware is compatible with yours.
First, make sure to extract the firmware .img file to a folder like C:\temp or whatever you like.
Then, follow the right procedure to flash the firmware: by pressing and holding +, at the same time connecting the usb cable. Then, while holding + button, immediately short-press Power button up to 10 times until you hear a sound and a pop up window with instructions. Release + button now.
Good luck.
Sep 10, 2012
When you think you have bricked your mono. You need to do a hard reset.this involves pressing the power key and reset at the same time. You will know when this has worked because when you plug in the mains or the USB the charging screen will be displayed. Live suite will not work unless the tablet is off and this is the best way to be sure. Charging screen means its off.Once you have achieved this and it can take quite a few attempts. Run live suite and your tablet should be back.One the best points about player tablets is they are virtually unbrickable.


Sep 24, 2012
Hey guys, I have a MOMO8 which was running with some problems on Android2.3.4, so i went and updated it to 4.0.3 using LiveSuit. I was able to get everything properly updated, even the "Update Succesful" screen, but the device just won't boot... i've tried various imgs for the 4.0.3 found over the internet, both from ployer and other sites, and it all ends up the same way, just a black screen which does not do anything.... any ideas???



Senior Member
Nov 8, 2011
There are two versions of momo8. One is called momo8A the other is momo8S. The S version most likely stands for sucks, lol. Anyway I had an A it broke and was given an S as replacement. All roms are for A but one, the TB2 rom will work on your version.