Prestigio PMP7100c / Archos 101


Sep 2, 2011
So, yesterday I bought a Prestigio PMP7100c.
Got home, turned it on (something weird was no startup wizard appeared...) and played some Angry Birds, some chess, and I tried to set up WiFi...
I turned WiFi ON, chose my home WiFi network, and the thingy said 'connected'.
Then, I couldn't get to the internet. I did everything the instruction booklet said to do, and no app in need of internet worked!
So, I conected it to my PC running w7.
And the PMP said 'Data corrupted, you may have to reformat'.
So, went to settings, and chose 'Reinstall Android' ( or something like that...)
It said 'turning off' for the whole night, and, in the morning I left it drain its own battery.
Later (6 hours later) I got home, tried to turn it on, couldn't, plugged it in the charger, it charged and I was finally able to turn it on.
So, the homescreen wasn't like the original PMP... No weather app, the same thing (almost) as the GalaxyTAB has for its homescreen.
I tried again and again, no internet site loaded.
I updated the OS via my PC, still, no internet working!
Can somebody please help?
Everything that was on the tablet was erased, but I'm not worried about that, because all the apps were free.
So, any suggestions for the WiFi?

And, strangely, my PMP shows no password is needed for my WiFi home network, whilst on any one of my WiFi enabled devices, I always have to have a code...?
Last edited:


Aug 1, 2012
Well for your edit i can tell you that Prestigio tablet and i think android tablets in general remember the passwords after single entry. As for the reason it doesn't work i have never encountered something like this on a Prestigio tablet apart from a single device that had an incredibly short WiFi range. Try getting closer to your internet router/modem and see if that solves your issue. Apps that come free with the tablet can be re-acquired for prestigio store for free.