Proscan PLT8235G


Junior Member
Apr 6, 2014
Hi not sure if this is the right forum but here goes.

I bought my son a Proscan tablet for Christmas and every 2 weeks it starts messing up.(Does not matter if we download apps or not) So everytime it starts to mess up we have to set it back to factory setting

How it messes up is we get pop ups constantly popping up over and over again repeating the same messages.

These are the messages...
-Unfortunatly, Picasa Uploader has stopped
-Unfortunatly has stopped
-Unfortunalty Google+ has stopped
-Unfortunatly android.process.acore has stopped
-Unfortunatly process has stopped

These keep popping up over and over even though I click the OK button. Its hard to set it back up to factory because the pop ups dont stop, so I quickly have to press OK then try and click on the reset button. I have reset it and left it for a week un touched and turned it on a week later and these messages are popping up.

Someone please help! Did I get a dud tablet?


Junior Member
Jun 22, 2014
Hi there. I bought my mother the same tablet and she has been having the exact same problems. I tried to do some trouble shooting for here and its doing the exact same thing. Have you found any resolution for this? Or anything?


Junior Member
Jun 8, 2014
Hi. I had problems with mine as well, for some reason it quit finding the apps that I was using and would not shut off except with poking reset. From that time on every time I started the tablet it went through a factory reset and I had to enter all setup data every time. It also would not update any of the apps that are standard and I could not install any new apps. For updates kept getting message 'Not enough memory available'. To make a long story short, I wnt to CURTIS INTERNATIONAL - manufacturer and distributor of quality consumer electronic products and found a firmware update for the PLT 8235G. after following instructions with it using sd card my tablet is back to normal and can now download apps and updates.
Probably is worth a try before tossing.
Hope it works as well for you.


Junior Member
Dec 9, 2016
ive had that tablet for 2 years now and i got it rooted and it works fine,the ram is bad but i fixed it with roehsoft ram expander