RCA Tablet Problems-HELP


Senior Member
Jan 13, 2014
Hi, I purchased a 7inch RCA Tablet almost 2 years ago, it was pretty full, I started to clean it up and the wall charger broke so I purchased one thru amazon it wasn't quite the same but it worked and then one day I was listening to music thru one of those small speakers that plug in and it just died. Ive tried to reset it, reboot it and I've watched some you tube videos and tried to wipe it clean and reboot it and its just not working. On one of the videos it shows the android man with the words "erasing" on the screen, i never get that, mine will just read "wipe complete" and when I try to reboot the only thing that comes up are the two dogs, it never gets pass that. Sometimes when I try to turn it on it will give me a quick flash, which makes me think its blown. Rca support says it sounds like a software issue, which is even more confusing to me, It's out of their warranty and that's all they could tell me. So I'm writing all this because i was hoping someone out there could help, tell me what i'm doing wrong, or how this could've happened. This is my 2nd tablet to fail in 2 years and i'm getting ready to give up android-Please let me know if you have any suggestions. Thank you.


Staff member
Mar 24, 2011
Hi TechNewbie, sorry to hear you're having problems with that RCA tablet. I'm moving your thread to the Android Tablet Q&A section of the forum for you, where more people familiar with that tablet are likely to join the discussion and try to help you. Good luck!