Sero 7 Pro won't boot


Junior Member
Jun 21, 2014
I have a Sero 7 Pro with custom ROM sero7pro-bld60220-dopa-v2.0 installed. It had been working fine for months until the other night when I picked it up and it was powered off. It was plugged in to my PC usb port like I usually keep it so the battery should have been fully charged and I don't know why it powered itself off. Now it won't boot up. It sticks on the bootanimation screen. I tried to get into Fastboot using the volume/power button but it just hangs on the Fastboot screen and never goes any further. I am able to get into Recovery and have tried various options from just clearing cache and data to restoring the original ROM using sideload and Adb on my PC. I then copied the stock-v60220-full-update to the external SD card, mounted the external SD, cleared cache and data, and installed the zip. Recovery said it installed but no question about stock recovery or unroot. Nothing allows me to boot beyond the bootanimation. I have also tried to replace the file in the /system/media folder but it continues to try to boot with the same animation file. It almost seems like memory is set to read only mode. Any ideas what might be wrong? How do I retrieve a log file to help diagnose the problem? Is there any possibility that opening the back cover and disconnecting the battery will reset things? Any ideas?