Supersonic SC-999 Won't Charge

marilyncloud

Junior Member
Mar 23, 2015
3
0
I have a 9"Supersonic SC-999 Tablet that will not charge. When I plug in the charger no lights come on. If I push the on button it shows a picture of a battery with no charge left on it and a triangle with a line through it. Can anyone help me? I have only had this tablet for 8 months and up to this point have not had any problems with it. Any help help would be greatly appreciated!!
 

leeshor

Senior Member
Dec 27, 2011
6,331
1,037
Welcome to the forum

Do you have access to any other charging bricks you could try? Also try plugging it into a running PC with the tablet off for several hours to see if that makes a difference.
 

marilyncloud

Junior Member
Mar 23, 2015
3
0
Yes, my brother has the same tablet and I tried both of his chargers also. No change. I will try plugging it into a running PC and see if that charges it.
Thank you so much for your response!
 

leeshor

Senior Member
Dec 27, 2011
6,331
1,037
Did you also use his cable? If so let that "trickle" charge on the computer run at least 5 hours.
 

marilyncloud

Junior Member
Mar 23, 2015
3
0
Actually I am using a cable that I had on hand. From a previous tablet I owned.It has been on the computer since I responded to you earlier. I plan to leave it on another hour or two and then check it.
 

Tow Captain

Junior Member
Jul 7, 2015
1
0
I have a 9"Supersonic SC-999 Tablet that will not charge. When I plug in the charger no lights come on. If I push the on button it shows a picture of a battery with no charge left on it and a triangle with a line through it. Can anyone help me? I have only had this tablet for 8 months and up to this point have not had any problems with it. Any help help would be greatly appreciated!!
I had the same problem after trying for a month to charge it doing the same thing as you pushing the button and the battery would come up then go away. I decided what the heck
Try anything I kept pressing the start button over and over and finally the battery symbol stayed on and charged up. I think the problem was the battery to dead to charge.
 
Top