Tablet won't install apps


Junior Member
Mar 4, 2016

I got a very confusing error with my android tablet. Its a cheap china tablet, it was sent to me with a virus so i removed the android os and changed to newer 4.4.2 with root... The tablet is running everything is fine but i got a little problem. I cant install any application on the tablet. Yes the G. Play store allows me to downlaod but it wont install : Error -110. I tried to put the apk on the sdcard but same result the app wont install this time without error code.

What can be the problem ? Thank you everyone


Staff member
Jun 16, 2012
Why error 110 pops up isn't known, but it may be one of the following reasons:
  • You installed a custom ROM.
  • You updated your version of Android and it may not be compatible with the hardware.
  • The apps you are trying to install are not compatible.
As a possible solution, force close the Play Store app and clear its data and cache. Repeat the process for the Google Services Framework, and reboot. Then try to run the Play Store again and see if you can install the app. If that doesn't work and you need to sideload an app from your MicroSD, make sure that "Install From Unknown Sources" in the security settings is enabled, and then try installing the app.

Should neither option above work, you'll need to exchange the tablet for a working unit.