TF300T Update Help

peterjcb

Member
Mar 2, 2013
3
0
Hi everyone,
I'm kind of a new Android user...
I purchased an Asus tf300T with Ice Cream 9.4.3.30 installed quite a while ago. I unlocked & rooted it but life got in the way and I put it aside until now.
I would like to install Jelly Bean but for some reason when I go to update the firmware it claims that there aren't any updates available. It simply won't do an OTA update.

I went directly to the Asus website and downloaded the correct firmware for my current build version but I'm stuck at the next step...
The instructions now say to:

"1. Check SW version of your ASUS Transformer Pad TF300T*
2. Download ASUS Transformer Pad TF300T Firmware: V10.4.2.20 Only for JP SKU and Update version of SOP (From “Manual” Item)"

I have not idea what the instructions" Update version of SAP (From "Manual" Item)" means....?
Can someone point me in the right direction?
Thanks!
 

idontknow

Alternate ATF App Tester
Jan 13, 2011
2,102
175
Hi peter and welcome to the forum.I would love to help you but I'm a galaxy girl! :-D The best think you can do is to go to asus forum and ask your question there or look at the threads there, you might find your answer. I'm sure Spider, our administrator will move you there but over the week everybody on the forum takes it easy, so you might do faster on your own. I'm glad you can finally enjoy your tablet!
 

Spider

Administrator
Staff member
Mar 24, 2011
15,786
1,813
Hi Peter, welcome to the forum, nice to have you as a member of Android Tablets. I'm moving your thread to the Asus TF300 Forum section for you, where more people are likely to join the discussion and try to help you get it updated. Good luck!
 

leeshor

Senior Member
Dec 27, 2011
6,330
1,037
Hi Peter. From your description it sounds as if you may have downloaded thew wrong version. go into settings about, and double check the version that you have now. Then get microSD card formatted FAT32 and extract the first zip file to the SD card insert card and restart your Transformer. You will lose root and in fact if you are unlocked you may have additional problems. I only say you have the wrong version because it appears you're in the US and it doesn't seem like the version you download from ASUS.
 

peterjcb

Member
Mar 2, 2013
3
0
OK, I talked to a friend this morning and it seems that since I unlocked my Asus TF300T tablet, I am no longer able to get OTA updates and apparently it is not reversible.
I have Clockworkmod installed and the tablet is rooted and unlocked.

I booted into Clockworkmod recovery mode and tried to install a Cyanogen ROM. I cleared the dalvik cache and the cache partition.
When I tried to install the above downloaded .zip file it’s giving me and error and aborting the installation.
Here's the error message that I'm getting:
Installing: /sdcard/cm-10.0.0-tf300t/cm-10.0.0-tf300t.zip
Finding update package...
Opening update package...
Installing update...
assert failed: getprop("ro.product.device") =="tf300t" II getprop("ro.build.product")
Ot"
"E:Error in /sdcard/cm-10.0.0-tf300t/cm-10.0.0-tf300t
(Status 7)
Installation aborted.

Direct Download: cm-10.1-20130303-NIGHTLY-tf300t.zip
md5sum: fe2677c76ff0d2984e36941249d6923c Short URL: http://get.cm/get/6wz
 

peterjcb

Member
Mar 2, 2013
3
0
Thanks for all the responses, I finally got Jelly Bean installed after hours of trial & error.
I am officially on 4.1.1
Not exactly sure what ultimately solved the problem but just glad to finally get rid of Ice Cream!
The only problem now is that my device has lost it root. :(

Sorry for all the questions but my next question is...how to I get my root access back?
It is still unlocked but when I used
root checker" it says..."this device does not have proper root access."
 
Top