USB problem. Please help.


Jul 31, 2012
Hello all,

Before I begin explaining the USB problem I have, here's some information on the Tablet I own-

Coby Mid7120
Android version- 2.3.3
Kernel Version-

It's has 4gb, 7 inch LCD, and an 800mhz processor.
I actually bought this one roughly a month and a half ago. Afterwards, I purchased a keyboard for it and it worked beautifully; that is until recently.
The keyboard has stopped working altogether on the Kyros; but it does work because I'm actually using this mini-keyboard on my PC at this very moment.
Initially, I thought that perhaps the mini USB port on the Kyros went bad; but that's also not the case. I'm able to connect the Kyros directly to my PC and it recognizes the device.
On the Kyros itself, the USB seems "dead" in the sense that anything I connect to the mini USB does not work whatsoever.

I've tried buying another female-to-female usb piece to connect usb's; still no luck.
I'm very frustrated with this; and have spent the better half of a week trying to fix this issue. I've even browsed through these forums and seen nothing related to my problems.

The only indication that the mini USB "does work" would be that it will signal a very "quick" flash on the keyboard when connected.

Please help. Thanks.


Jul 31, 2012
Hmm strange indeed, have you had any other devices you can test on the droid?

If not i guess the usb port is simply not providing enough power.

Yeah. I've tried MP3/MP4 players, Digital cameras...etc.

I'd assume the USB port would be bad but the PC recognizes it. I even assumed the cable was bad, but they work.



Junior Member
Jan 29, 2011
I think your PC is finding it as the PC is also powering it at the same time with a charge.

The data pins may be damaged :(