ViewPad 7E1 Not Doing Anything

AlmightyBlobFish

Junior Member
Aug 16, 2015
1
0
Hi,
So I recently found an old ViewPad of mine, and I remember not using it because it stopped working for no reason. I decided to look into it again, but it isn't reacting to anything. The only thing it does is the red light turning on when the charger is connected, and sometimes the screen flashes for a moment when I try to reconnect the battery. My PC doesn't recognize it at all, but the ViewPad is charging when connected (at least the light is on). I have tried putting it into recovery mode with the volume up/down and power held, I have tried putting a toothpick into the reset hole thingy, but it doesn't do anything.
It's a ViewPad 7E1, model VS13761 I guess, at least it says so on the back of the box above all the barcodes.
I hope someone can help me with this.

Regards,
Julian (AlmightyBlobFish ;))
 
Last edited:

leeshor

Senior Member
Dec 27, 2011
6,331
1,037
Welcome to the forum

It may be dead but there is another thing you can try.Plug it into the computer, with the computer awake for at least 5 hours to trickle charge it. Then try turning it on again.
 
Top