Downloading apps problem

Discussion in 'Asus TF101/SL101 Forum' started by surfinchina, Oct 26, 2011.

  1. surfinchina

    surfinchina Member

    Oct 26, 2011
    Likes Received:
    Trophy Points:
    Tablet / Device:
    Asus Eee Pad, Samsung Galaxy s2
    I'm new to android.
    I have an asus transformer and a samsung galaxy s2 which I got in China (I live there).
    When I try to download an app on the Asus it spits me to some weird installer which is in Chinese (Aptoide doesn't do this)...
    The Samsung is fine.

    Is there a downloading app that I can use to replace the Chinese one?
    Will I have to root the phone?

    I tried uninstalling the chinese app (after backing up), but it won't go away...

    I've tried downloading lots of app installers, but the only one that came up as an option was It crashed.

    Thanks for any help you can give me.


Share This Page

Search tags for this page

downloading app on samsung in china


downloading apps in china


problem downloading apps on samsung tablet