Games that are not compatible with my Zenithink 280 C91 upgrade

Discussion in 'Zenithink ZT280 C91 & C91 Upgrade' started by stevohaker, Apr 13, 2012.

  1. stevohaker

    stevohaker Member

    Joined:
    Feb 17, 2012
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    Banja Luka/Bosnia & Herzegovina/Republic of Srpsk
    Tablet / Device:
    ZT 280 C91 upgrade
    I downloaded and installed few games, but they don't want to run.
    They say that my device is incompatible.
    Can I update firmware from Zenithink site, because I don't know is my tablet rooted?
    Can I loose root?
    Games that wont run are 'Ice Age village', 'Oregon trail :Settlers'.
     

Share This Page