Coby Kyros MID1126 HELP! Cannot Boot, Need Firmware :-(


Dec 17, 2011
Hey all!

I'm currently sitting with a semi-bricked Coby Kyros MID1126 (4GB)... Here's the situation...

I messed this up trying to install the german ICS update, and I never made a backup. I'm not sure if using Clockwork messed it, or writing a 1125 copy of the ICS rom, but the story now is I've tried writing 8127 Roms, 1125 Roms, etc. Nothing left of the original firmware!

One kind person helped me with a copy of the 1126 stock but the system file is in .tar format. I think this is installed with the KTZ Recovery, but that's in RFS format I cannot boot into it. Clockwork runs, but I have no .zip CWM format backup.

I've also written the images in fastboot, boot.img, recovery.img, (from that 1126) and attempted to write the system files from the .tar by uncompressing it on my PC and pushing it to /system/ using ADB PUSH. Didn't work.

So it's not totally bricked, it will boot into a hanged logo or a bootloop (depending on what I've flashed) and if I try writing the system as above it'll boot into the stock "recovery 3e" (with the dead android, warning triangle, etc). As for the ICS... originally I could boot into the german 1125 version but with no touchscreen. If I flash the 1126 boot.img I do get a touchscreen (a strange one.. a circle you can drag around and tap) but it'll hang at "updating apps". I tried controlling the 1125 ICS without using the 1126 boot with a mouse, but there was no wifi...

So now I'm at my wits end. The net has nothing, plenty for 7" models, and I did find a rom to be flashed using FDWN (which I won't except as a very last resort!) and perhaps 3 forums - including this.

What I'd really love is a ClockworkMod version of a working or stock MID 1126 to be flashed in the clockwork recovery (I've used V5 and one titled 1125_recovery which looks like V4).

If it IS the Clockworkmod that's causing problems, I can also get fastboot, and flash .img files...