Coby Kyros MID8127 No Boot


Dec 16, 2013
Hi guys!

I have a tablet, Coby Kyros MID8127 with 2.3. I want to upgrade a version, downloaded update aplication from coby official website. After install the tablet doesn't booting, android logo loading but don't step forth. I'm waiting long time, because i can't power off. Push the reset button, make again and again....

Battery discharged the tablet powering off. I read forums and found a FWDN software for my tablet. I followed the instructions....but the installer finished the tablet doesn't starting....only menu, home and back LED lighting, screen not. I'm can't power off this machine, when the battery full discharged only then no lighting. I try connect the changer, after hold power and volume up-down buttons....but not working.

What i doing? :confused:Help me isn't my tablet, i must repair that...

thanks for help:rolleyes:
Hy Petika.

I am having the same problem as you. I did the upgrade of my Coby Kyros MID1126 from a Coby Germanu site. It worked normally for 24 hours.
After that it simply boot and I got the same issue. I don't boot. It keeps on Android Logo and do not turn on.

Did you get any response about this problem?

Thank you in advance.
Have you tried a hard/mechanical reset to revert back to the factory settings?