Fails to connect to wifi (worked before, other devices still ok)


Mar 30, 2013

My Nexus 7 is reporting 'authentication problem' when trying to connect to my home wifi
I get the same error if I try to connect it using my Nexus 4 as a hotspot (this also used to work fine)

I've never had this problem before (have been using it since last summer)

My (new) Nexus 4 and (old) laptop have no problems with my home wifi.

Have restarted wifi hub - doesn't help
Have 'forgotten' the connection and re-entered password on Nexus 7 - doesn't help
Have tried changing to static IP on Nexus 7 - doesn't help
Have tried disconnecting Nexus 4 in case the hub had max connections - doesn't help

Any ideas?

Thanks very much,
Welcome Jenny
The best suggestion I have at the moment is to find a public hotspot or a friend's WiFi to see if the problem is the tablet.

You could also try eliminating the security from the router long enough to check it. One more thing, newer versions of Android don't like security with special characters, even - and _ can be a problem for some tablets.
Thanks for the reply.

I just tried again and it DID connect (it even managed to download some messages), but within seconds dropped it. And again. And again. It's currently automatically cycling through trying to connect over and over (previously it just sat there doing nothing).

Trying to connect to other open networks it tries (and is still trying) but then nothing happens - it just goes back to saying "Saved" for that network.

So, annoyingly, it's now exhibiting different behaviour now, but with the same outcome: I still can't d/load all the stuff I need to get on there :(

Yours frustratedly,

PS there are no funny characters in my home or Nexus4 network names or passwords, but thanks for the tip, will avoid these in future
PPS I don't know how to eliminate the security but will go and rtfm!
Last edited: