FlyTouch 2 Android Market not responding


Feb 2, 2011
I purchased a Android Tablet, I was told it is FlyTouch 2.

When I start the device, the first screen shows 'InfotMIC', and then a green like screen
that has 'Powered by WowPad' displayed on right bottom corner.

My first question is if it is a FlyTouch 2.

And, I set up gmail with this device, and for the first couple of weeks, everything looks ok. Android Market works fine and the updated market shows since the device has Android 2.1. However, when I tried to update to Android 2.1 updated version through update in settings. I was asked to reboot, every time, I reboot it, the device is stuck at the first screen that show 'InfotMIC' and never goes on.

I tried several times, it did not work, and I gave up.

However, then one day, the device was dead by itself, and I reboot it, and since then,
Market never works. It always pops up server error and asks me to go back.

Can any one help me solve this issue?

Or can someone tell me how to change gmail account with this Android device?

Thanks in advance

Just go to Settings > Installed applications, choose Market from the list and then click button "uninstall update". After that Market should work as usual.
Thanks for the reply, however, I did that already, Market still doesn't work.
And, I think it is because the gmail I used to register the device some how is not associated with it any more.

Where and how can I reset gmail with the device?