FlyTouch2 unboxed and unable to switch on


Dec 23, 2010
revived a FlyTouch2 and plugged it in to charge

red light stays on constant - left it charging a few hour and tried to start it up
pressed the power button -no vibrate and no start up

held down the power button 2 secs again and nothing - 4 seconds nothing 10 seconds nothing

left it charging for another few hour and tried again - still nothing

pressed the little reset button and tried powering up - nothing
tried the 3 button reset i read about on-line and nothing

emailed the place i ordered the unit from and they offered to post out a replacement battery - but i don't even know how you would open the unit it change the battery - there are no screws - would you need to pull the screen out? would that damage the screen - would it void the warranty ?

Sorry about all the questions - im just at a total loss and am gutted that i cant even get it to start up after weeks of waiting for it to arrive.

Thanks in advance for any help anyone is able to give
I have the same trouble with the last flytouch2 result: the switch button was broken (unsold on the board).to open it's necessary to remove the four silver round top on each corner and under you will found 4 screws to open it be worry with the screen connector !!!
thanks for your reply

the full back piece is one section and the edges with the slots and buttons is also part of the same piece of moulded plastic

there seems to be no removable sections at the corners - and there are no screw covers that could be removed to provide access to screws

again if i am simply understanding then i would be glad to be corrected - i bough this for my g/fs Christmas and am gutted i now have no present to give her ( ok she can see i tried to get her something cool but a broken tablet is a pretty crappy present )

again thanks for the reply and a broken power button would explain it not turning on - still it leaves me wondering why it wont take a full charge tho - light is always red even after 8 hours on charge

mine just goes to the green screen that says powered by wowpad and nothing els i just got it today too :(