Help!! 911 Coby Kyros 8125 BRICKED!


Oct 7, 2011
I’m afraid I think I bricked my coby kyros, I would like to know if anyone could help, here’s my problem:

I tried, stupidly, to root my kyros with the program FWDN, everything was going according to a tutorial I found on the int. later on when I had the lk.rom , the nand fai file and the tc8900 img file i selected the low level format(big mistake but I was just following the tutorial) anyway, I clicked on start, and right after the program finished formatting the NAND (T_T) it gave me this error:
And also sometimes an error like:

CFwdnPort::FWDN_Normal_Rsponse: FWDN Response Parameter Failure

Now after that my coby kyros just stays on a black screen with the button’s on:


Sorry about the bubbles, but the screen is full black

And after that I tried unplugging and plugging it again, and i heard that my comp detected something but nothing shows up

If I leave the FWDN open and I reset my tablet and I plug it in again I get the same error from the beginning .

I also noticed that by closing the FWDN and connecting my tablet and I went to the Device Manager I noticed that what my comp recognizes is the Telechip processor from the tablet.
I don’t know what to do I really screwed up the tablet,I know there’s NO documentation for this tablet on the internet and either for the 8024, and never, NEVER count with Coby to help you with anything, I sent an email about a wifi problem and I will die expecting response. There’s also NO firmware publication for this tablet yet on Coby’s website, the closest one is the 8024 but they changed processors so I believe I can’t force the firmware.
Anyhow the tablet is not doing ANYTHING I mean it, tried pressing down all combinations for startups like FWDN mode and so on, but it stays on black screen and button’s On.

If anyone can help me I would really appreciate it..

Thanks in advice!
There is no official ROM for any of the x125 tablets so far, so it will be hard... You can try one of the many tutorials for 7022, since they both have the same processor, but you will then have to modify the screen drivers at some point because the 7022 has a capacitive screen.
I see.. but how can i put the ROM of the 7022 ? will i get that error in the FWDN? or that error is because of the wrong ROM?
Sorry, no idea since I don't own a 7022 or any tablet that uses FWDN. If no one else pops up here to help I suggest that you join any thread about 7022 FWDN and ask for more info.
Ok i did what u said, it went smoothly now when i connect the tablet and turn it on it stays on a white screen (kinda like if the screen was damaged) but i believe its because of the drivers, and the USB devices says "android gingerbread" ..i guess i have to figure out how to change the drivers? lol that sounds kinda impossible:p soo least the screen now is white xD..if anyone have any other ideas! plz help!! thanks lfom!!!
That's the problem when there isn't an OFW: there is no info about anything...

Look in the 7022 firmware u-boot files, look for "lcd" and get the code. I know the code for 7024/8024, so maybe yours is the same. If you hexedit the code, then it may work. But it may also brick your tablet, so it's dangerous, I can't guarantee anything.

You can also try using the HMDI to make sure everything is working.
Look in the 7022 firmware u-boot files, look for "lcd" and get the code. I know the code for 7024/8024, so maybe yours is the same. If you hexedit the code, then it may work. But it may also brick your tablet, so it's dangerous, I can't guarantee anything.

Forget about this, it seems that firmwares for Telechips boards are completely different from ones used in Samsung boards.

You will have to talk to someone else who knows more about those tablets, like fun. He has this page with a bunch of custom firmwares:
Telechips custom firmwares |

Be very careful, as there are warnings of possible bricking.
ill see what i can do, anything ill post here again, thanks for ur help lfom! ill check that website
hi to black screen on tablet coby kyros e have one soluction but is in portugues translate my forum and see if you can restore your tablet : Coby Kyros Soluções

This doesn't work for 8125, only for Samsung based tablets like 7024/8024/1024.

Also, the instructions are far too long, with unnecessary info (all Kyros have NAND) and a few errors not to mention that it uses an outdated version of my GingerLF.

The original thread where it was documented how to fix a hard bricked Kyros is here:
Last edited:
I have with the same probleme problem with my coby 1125. I try to install a F1 custon rom from KZT and my coby frozen in coby logo. Try everythig to recovery ( I have all the recovery files images) but nothing works. The last step ( I think a wrong step) was to use the FWDN program and install the 7022 files ( and TCCXX.img). Now my coby is with a black screen. It's almost dead, but still acess with fastboot and FDWN program. I think it will only revive if we get the correct lk.rom and TCCXX.img files.

Question In some tutorials have these files ( lk.rom tccxx.img, etc) to the coby 7022, 7015, 7020. Does anybody know how get this files? These files are stracted from firmware file?

I wrote to coby technical support ask for the firmware and files... but....

tks a lot and if news I will post.

Hi a friend from other forum give this link, It is possible to create you own tcc_8833_mdt.img. But you will need some images from 8125 system.img: recovery.img, boot.img.

I have this images from my coby 1125 but i think it are brokened.

see: the link:

unpacking and packing tcc8900_mtd.img (not fully working) -

only read the part that he tell how pack the tcc_xxxx.img

after that you get the files, you will need a computer with linux, to compile the file "tccpack.c" and execute tccpack like is wroted on link.

by the way if someone has the 1125 imagens ( recovery.img, boot.img, system.img) , please upload that I am trying to recovery my coby 1125.
You just press the reset button on the back of it then HOLD DOWN the silver orb back button. Then a menu will show up. Go and up with the button on the side. Highlight the option "Reset to factory" then press the silver orb button again. Then it will load then highlight "Reboot device" and press the silver orb button. Now,you device will reboot and your device is now fixed and unbricked. And they they it's hard to ;)
Last edited:
I am still wondering if you are having trouble regarding your inquiry. Please reply. Thank you!