Help! Black Home Screen


Jul 1, 2011
Hi All

I just received an Archos 7 Home Tablet (v1) from Woot. i just wanted a cheap simple tablet to store pictures and get e-mail until the Samsung Galaxy Tab 8.9 is available.

I was able to get the unit started up okay. I installed a few Apps like Angry Birds, Facebook and my gmail account. I also tried installing some updates to upgrade Adroid. The updates didn't work but the tablet was still working okay.

About an hour after using the tablet, I got an error message ( and process android.process.acore) upon startup and my home screen is black. I'm able to touch the home button, settings button, volume button and attention button but none of them actually do anything except the volume button.

I tried calling Archos but support is closed prior to the stated time.

Can anyone help me?
Last edited:
I just bought mine too from Woot and received it on the 2nd and I tried to install 2 apps and then I got the the error message also now it is just stuck in a loop and won't go anywhere. I am currently trying to drain the battery, but I have read in other forums that draining the battery has not worked. I also was watching on you tube and someone mentioned that best buy sells archos. I am not sure what they would charge to fix it if they can but I did e mail both woot and archos to see what I need to do and or whom I need to send it back to. If anyone know how to fix this without sending it back to the manufacture I could appreciate it.