How to Root a Coby Kyros MID7016


I followed all your steps and it worked I did get the android market to appear, but when I open it and try to download any app the market force closes on me everytime... :( help plz

Try removing all of the files and installing again. Make sure you reboot again before reinstalling the files. It took 3 tries installing and uninstalling these files before I got the marketplace to work. But now it works and makes this a much more useful tablet.
I must be a complete idiot- I can't get it to run. It says download fail... can you give me the extremely lame mans version?
after hard work and a lot of trials here is the solution ............... it is superoneclick 2.2 from here ..... and then make shell root then root and it will be rooted
hey danilo, could you break it down a little bit more, i downloaded the file from the link on my computer and i open it and its a lot of files i don't know how get the onetime, setup apk, do i have to download those also?????????????????????????????????????????????
The files for superoneclick need to be installed on the computer... I used the version 2.2 to root my coby 7016 some weeks ago, it work´s perfectly. I am trying now to modify the wpa_supplicant but its hard,,, till now I manage to install the clockworkmod but it´s the new version and I can´t apply the zip to update the wap 0.6... this new version of clockwork have some issues... :(