need help finding firmware upgrade for generic flytouch! wmt2.0


Dec 22, 2010
heres what i got

mem 256mg

model generic

firmware 1.6

kernal 2.6.29-00236-g4f8dbbb-dirty

build number wmt2.0 - that all it says is 2.0 nothing after it


anyone have any idea what firmware i could use? also if you know where to get this original firmware just incase something happens during the upgrade? thanks everyone for the help and happy holidays!
man no one has come across a tablet with build wmt2.0 ? nothing after it just wmt2.0!!! ?????
Hi gusrod1580. If it has a blue power LED and a green headphone jack try this one. It fixed mine. A very nice person whos handle is anbrick gave it to me and it fixed mine. get it here:

RapidShare AG, Cham, Switzerland

Maybe it will fix it. It worked for me and another guy. One guy reported it did not work for him. If you are bricked go for it.

Hope it helps

Hi gusrod1580 . No it is a factory 2.1.1. If you have the blue LED, green headphone jack model I wouldn't change roms until they can positively ID this model and release a working rom for it. I tried over twenty roms on mine before anbrick gave me the one I posted above. It is the ONLY one that worked. I will be waiting to see if they are able to do something with this model before I try it. If you have not bricked yours yet and you have the same model as me don't load anything for a while. You will be sorry if you do.

ya luckly i bought it locally from a computer shop and i changed roms and just brought it back and exchanged it for another one =)

I tried the ROM you posted but got a

-->Not find UDisk (/dev/sda)

Fail to update filesystem. Exit!

Any idea? TIA