Ut oh.... aPad won't turn on


Super Moderator
Staff member
Nov 26, 2010
I charged my aPad lastnight, and when I tried to turn it on this morning.... nothing.

The red light stays on while the USB charger is plugged in, but once I remove it the light turns off. I've tried every combination to turn the device on, but it just will not start.

I also plugged in the mini-USB to see if my computer would detect it... but nope.

Any suggestions?
Interesting when I plug in the USB charger (by the charger itself) there is a loud pitch humming noise.... ok so now... how do I open this thing up and take a look-sie?

Edit: This was quite easy to open up. Just placed a flat edge under the black hooding on the top of the tablet. Popped right off... i'll get my mini-screw driver once I get home.... and see if I can see anything.
Last edited:
Update.... the high pitch hum appears to be coming from the speakers....
Problem fixed: Appears the LCD cable was loose... the inside of this tablet is poorly put together. Anyways.. re-attached and working!