Android Tablet Will Not Start; Frozen On Logo Screen

Discussion in 'Android Tablet Q&A' started by Jeff6146, Aug 27, 2015.

  1. Jeff6146

    Jeff6146 Junior Member

    Aug 27, 2015
    Likes Received:
    Trophy Points:
    I have a DOPO D-7015K Internet tablet that was working very well for me, until today. I turned the tablet off, restarted it, and now it will not go beyond the DOPO logo screen, regardless of how many times I reset it using the hard reset method (press power button and volume up/down buttons) or the reset button on the back of the tablet. Is there a simple fix for this problem?

    I have left it on for quite a while; in fact, the tablet is still frozen on the DOPO screen as I am writing this. I also tried leaving it on charge for a half-hour earlier this evening and tried charging the battery for several hours this afternoon; no luck.

    Note: This tablet is well over a year old, so it is out of warranty. I am not particularly attached to it, but I don't want to get a new one if I can avoid it.

    Thanks much.

    Jeff (AndroidTablets.Net username Jeff6146)

Share This Page

Search tags for this page

dapo tablet frozen


dopo tablet frozen