Asus Transformer won't power on or charge from AC lead

Discussion in 'Asus TF101/SL101 Forum' started by MarkTucker, Sep 3, 2011.

  1. MarkTucker
    Offline

    MarkTucker Junior Member

    Joined:
    Sep 3, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Sydney
    Tablet / Device:
    Asus Transformer 101
    Anyone know how to solve an Asus Transformer fault - won't power on or take a charge from an AC lead? The device is 3 weeks old. Looking on various forums, this appears to be a common fault with the transformer.
  2. ronirons
    Offline

    ronirons Junior Member

    Joined:
    Jan 13, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Naples, FL
    Tablet / Device:
    Huawei S7
    I have had that problem and finally decided it was a speck of dust or some other problem with the cable connection. I finally cured the problem by using a different brick temporarily. I then went back to the factory brick and it worked ok again. From that I conclude the problem was at the brick USB connection, not at the tablet end.


    Sent from my Transformer TF101 using Android Tablet Forum
  3. wricks
    Offline

    wricks Junior Member

    Joined:
    Aug 6, 2010
    Messages:
    13
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    North Carloina
    Tablet / Device:
    Asus Transformer (16GB)
    My wife had the same issue with hers. She took canned air and blew out the connections on the brick, both ends of the cable and the port on the Transformer. Whatever particulate matter that preventing it from charging was blown away. has worked fine since.

Share This Page