Momo 12 and 8 Won't Boot

Discussion in 'Ployer Momo Tablets' started by darnokos, Feb 25, 2014.

  1. darnokos

    darnokos Member

    Joined:
    Feb 25, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    35
    Hello,

    Sorry for being a noob in this topic but I have to learn somehow so....

    I have two tablets momo 12 and 8 and:

    Momo 12 was stuck constantly loading, somehow I got into recovery console and made factory reset, tablet booted up normally but after I tried to turn on the wifi the device just turned off. Now it wont get past first screen with a penguin. Also cant get to recovery mode again as the first time I got there was some kind of accident and I cant reproduce key combination that was succesfull.

    Momo 8 just like 12 is stuck on loading screen but of course never loads, I tried many combinations of volume + and - with power but no luck getting to recovery mode...

    Im new to tablet world but I tried downloading batchool it doesnt seem to recognize tablets but when I power on them connected to pc(windows xp) it detects unknown android device for which it cant install drivers. What drivers do I need ?

    Any help would be great
     

Share This Page

Search tags for this page

cant get ployer to go into boot mode

,

how to do momo tablet cannot boot

,

momo 8 recovery mode

,

momo tablet recovery mode