[SOLVED] WiFi Slowly Losing Connection

Discussion in 'Android Tablet Q&A' started by PSo, Jul 10, 2017.

  1. PSo

    PSo Junior Member

    Joined:
    Jul 10, 2017
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    24
    Hello, i have Prestigio PMP5570c duo and recently i ran into some problems. First i needed to replace a battery. I replaced a battery and tablet worked fine excpet i have one problem. Problem is when im not using internet its showing me full signal, but as soon as i open Chrome or Youtube or anything that requires internet my connection slowly drops to none. I would appreciate anything that could fix my problem.
     
  2. Future_Bringer

    Future_Bringer Junior Member

    Joined:
    Jul 12, 2017
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    12
    Factory reset helps you? Or you could try to open of your tablet and see if all of the cables are on the right place.
     
  3. PSo

    PSo Junior Member

    Joined:
    Jul 10, 2017
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    24
    Well first of all thanks for replying. I already opened it up several times and replaced the battery myself. I checked all wires connected to little antenna and it's all good until i close the tablet cover. I also did factory reset but it doesn't help.
     
  4. PSo

    PSo Junior Member

    Joined:
    Jul 10, 2017
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    24
    I fixed it finally... I found my tablet's firmware and installed it. It all works now.
     
    • Like Like x 1
  5. Future_Bringer

    Future_Bringer Junior Member

    Joined:
    Jul 12, 2017
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    12
    Nice to see it then:)
     

Share This Page