generic tablet stuck during boot, read only file system ?


Junior Member
Mar 24, 2014

I've got a generic Android tablet (from DX (SKU 111713), model TM7009, mfg unknown) that worked fine for a year or so until it was locked with a PIN which was promptly forgotten :( ... I couldn't get any help from DX but eventually worked out how to get into a manufacturing test mode by trying all the generic reset instructions (vol- on power up, be patient through all the splash screens is key). There does not appear to be the standard reset/recovery options described elsewhere but just some self test screens. All in Chinese though, guided by some image translation apps we managed to reset the memory and were operational again. To minimize further problems (I thought) I enabled USB debug this time and can now get into the adb shell anytime after it has booted.

Unfortunately at some point (possibly during a interrupted boot while USB connected) something in the file system was corrupted and the tablet now sticks during the vendor splash screen. I can still connect via adb shell and poke around the file system, kill the boot animation etc. but logcat indicates something about a read only file system. Following the factory-test menus again does not change the behaviour.

In addition to no recovery options it also doesn't respond to fastboot. I'm 'limited' to root access via the adb shell but don't know where to poke it to get it working again, any suggestions would be appreciated (is this forum a good spot or can you suggest a better place ?)

... Niall


Staff member
Mar 24, 2011
Hello Niall, welcome to the forum. Glad you decided to join us here at Android Tablets. Your thread is in the correct location for questions regarding a generic tablet. Hopefully someone will come along who'll be able to help you out. Good luck!