Google contacts/calendar - sync error


Apr 28, 2012
Hi everybody,

I am experiencing the following problems:
I've had a Google contacts sync error (running HC3.2.1) since January. It used to work fine before.
"Sync is currently experiencing problems. It will be back shortly."

The only thing I "changed" back then was to create a account since my (then) new Android phone running Gingerbread wouldn't activate without a gmail-email-address.
(I had already set up my Google account previously (years ago) using my personal non-gmail email address. Activating my tablet running HC with my non-gmail address was no problem at all...)

After updating to ICS 4.0.3 yesterday I also am missing my Google calendar data on my tablet. The data is still there since I can still access it on and my phone syncs fine.
I am not getting a Google calendar sync error message like I do with contacts but still all calendar data is missing on my tablet.

I've checked the Accounts&Sync menu, cleared all data, synced all Google accounts manually, to no effect.

Any ideas?



Senior Member
Apr 28, 2011
Well the obvious things I'm sure you checked, but just to be sure....

In your computer go to

Passwords. Check them maybe even change them.
Two Step Verification in your Google Profile (on the web). If you set it up, maybe want to re-do it.
Authorized applications and sites - check the list to be sure there are no un-recognized ones

Also check

Don't get crazy and start revoking access here until you understand what they mean.
Just because some web sites show that they are authorized to access the account, does not
mean they have access to everything. Lots of sites use google login service. When you log into
those sites, say or some such, they ask google to log you in and then tell them
who you are. They never see your log in credentials nor can they access your account.

On the tablet:
Under acounts and sync, tap each account and make sure each sub-element has a check box.
(calendar, contacts, email, etc). Then tap the menu (upper right corner), and tap
sync now.

Note: I generally turn off sync at the top where it says Iconia Tab. You want everything synced to google.