Help with Zeepad 7.0


Dec 26, 2013
Hi all. I bought four zeepad 7.0 tablets for my kids for Christmas. They all seem to work fine except for one which will not connect to the internet. I says that it is searching for networks but never brings any up. It also does nothing when I tell it to scan for networks. I have tried all of the wifi trouble shooters that were listed in this forum but no luck. The zeepad lists the mac address but says that the ip address is unavailable. I have tried to input the network information manually and all the screen shows is that the network is not in range. Any ideas of what the problem could be?
UPDATE. Another website told me to apply slight pressure along the sides of the tablet while it is laying face down on a towel. I thought this was strange, tried it and it didn't work, but when I picked it up and applied pressure around the edges without it laying down it must have done something because it came up with a list of networks. So I am guessing the antennae wasn't seated well.

Yes I have visted that thread and tried the suggestions. It is almost as if the antennae is not working in the tablet. It is not picking up any networks at all.I have also done a factory reset but still no luck.
My sisters tablet won't pick up internet. Its a zeepad and when I try to turn the WiFi on it just sticks and says to see WiFi turn on your WiFi... I have done a hard reboot 3 times and nothing works!!! Need help