I can't download to external SD card


Feb 27, 2012
I bought a new Polaroid tablet with ice cream sandwich loaded. I put in my 32GB micro SD card. I got the app "Move to SD". Here is the confusing part... The tablet has 4GB internal storage. When I move to the SD card, it moves to a 2GB internal storage folder. I had downloaded Aldiko to use as a book reader. When I go to my micro SD card do get the ebooks, I see a folder "SDcard" which is the 2GB internal storage, but there is also an "EXTSDcard" which is my 32GB micro SD card.

I cannot find any settings to automatically download to my 32GB micro SD card, and when I use the "Move to SD" app, it moves to the 2GB internal storage.

If I move, lets say, Angry Birds to the 32GB micro SD card, when I go to play the game, it says that I don't own it, so I have to download again to, you guessed it, the 2GB internal storage.

I had an older (about 6 months) tablet with Android 2.2 installed. I never had any problem specifying where to download apps to with that one and I never had any issues with the apps filling up the internal storage because everything was able to either download to or be moved to the 32GB micro SD card.

Is there something that I am missing here with the new Android system? How can I get apps to download to the external card, and why is there a folder called SDcard that is on my tablet that isn't my micro SD card?

Please, if anyone can answer this for me, it would be greatly appreciated.

[email protected]
If I completely understand what you are describing your main problem is that you CAN'T move apps to the external storage which may explain a lot. The Apps 3 SD apps may install on a tablet but were designed for a phone and just won't do what you expect. You also may be looking at 2 different parts of the internal storage, generally described as /sdcard and getting it mixed up with the external microSD card.
So, I can't move apps to my external micro SD card. I am not sure what you mean. Am I getting the sdcard and extsd mixed up? No. I see them both in my file manager. It doesn't make any sense. Why would they have a folder on the internal storage called sdcard when it isn't an sdcard. It says in the directions that came with it, "Use up to 32GB micro SD card to free up space from your internal storage. Stop getting, 'Not enough room' messages." Well, that is what I am getting, even with over 20GB of unused space on my micro SD card.
Most tablets only allow you to move files (music, movies, pictures, documents, etc) to the microSD cards.

Why is the internal storage called /sdcard/? Because originally the devices used a microSD card that mounted to the /sdcard/ directory. Now that devices have built in internal storage, easiest way to make sure all the apps work is to call it /sdcard/

Yeah, it is confusing, but it is just the way it is unfortunatley.

Try to free up some room by moving some pictures, movies, music, documents or downloads to your microSD using a file manager.
I have similar problems on my NATPC running ICS. I tried to set up an external sd card, got muddled about what was working and what wasn't, got a message saying card faulty, do you want to reformat? Said yes and promptly lost all my pictures files plus the app Quickpic. I have reinstalled Quickpic and have found image copies in "hidden files" but can't seem to move them to a folder in Quickpic, which is where they were originally. Any hints on a way out of the maze? The external card is now out of the slot and will probably stay out!
Welcome to the forum Maggie

You can make a folder, on your internal sdcard, then put whatever pics you want in that folder and QuickPic will (should) find them.
Thank you, Lee. I've done that successfully and sure enough, Quickpic finds the photo folders. That works just fine, and is a big relief! But alongside these folders are ALL the hidden images from every app I have loaded. Can I delete them safely? ie still have them showing in the app? Or do I have to find a way to put them back wherever they were to start with? As far as I'm aware they are not actually sitting in the Photographs folder I just created.
As far as I'm aware they are not actually sitting in the Photographs folder I just created.

I think that is a true statement so to keep you from confusing any of your apps I would leave them alone.

Glad QuickPic worked out so well.