I hope to find an answer


Aug 19, 2010
Hi guys, after reading almost all the post I have decided to post my issue with this Apad bought from Ebay
NEW Apad iRobot 7" Android 1.6 WIFI Tablet PC webcamera on eBay (end time 29-Aug-10 17:10:46 BST)

At first was impossible to connect to youtube and downloading any app from the Android market so I have decided to install the firmware 1.8.2 and after that tha Apad kept the screen stuck with the "Android" robot.

After that I decided to reinstall a stable firmware version that is the 1.6, kernel 2.6.29.,wmt sdk 1.7.4
I really think that this version is not suitable for my Apad because my touchscreen is not working anymore and I need to plug a usb mouse to navigate the menu (which as a different layout as well).
I have tried, again, today, to install another firmware version but my microSD (formatted to FAT32 and with only the "script" folder in it) did not work and I had the same result with another microSD.
I am struggling a bit as you can imagine and I am asking if I have any chance to have my APAD as before or I have to throw it in the bin.

Thanks for any help that you can give me!!!


Super Moderator
Staff member
Jun 30, 2010
Well if you flashed a firmware that wasnt suppose to go to your tablet your lucky you can even use a mouse to navigate but there is some good news that it isnt completely unusable my best advice is ask the seller if they have the stock firmware that would be the easiest way if not then you might be able to find help here just keep looking and trying