I Need Help!!


Dec 31, 2010
Good day everyone!

I just bought this android tablet (well it's generic. MID irobot tablet = iphone 4 style.)
I'm not pretty sure of what it's model is,

so the problem is that the time I used it, it forced itself to shutdown, i was surfing the net then a notification popped out. then force close,

i restarted it and boom, it's stuck in the boot sequence.:mad:

i tried to reflash it with firmware of the same build, another firmware and tried to downgrade the firmware,

but to my frustration, still no sign of improvement.:(

I took the risk of not returning it to the reseller so that i can learn something new, since i want to start studying android development.

anyways, this is the appearance of my tablet, i hope someone will identify it and help me find a way to solve my problem,


it's stuck at this part.


the ports on my tablet, i believe this is what we need to identify what clone my tablet is.


the top part.

please please please i need help. any help will be very much appreciated....happy new year guys!


Oct 26, 2010
Your device seems the same as I have here, but if I read how this went, I'm afraid your internal NAND drive is dead. Try my Uberoid, maybe you get more lucky ? PM me if you have any problems, please report where the upgrade fails if you PM me.
Last edited: