imx 8 nch tablet image: imx51_bbg android 2.2. Errors and Touch


Dec 25, 2010
Hi, [ Android 2.2 Cortex A8 8 inch tablet 800Mhz (Adv as 1Ghz), 512 Mb Model FR-809, Android 2.2 MID]

1. I tried to upgrade to enable market from one of the posts on this forum.
I did not saved or checked if there were previous apks so I've copied the new ones over.
I start getting errors as: The Application Google Services Framework ( ) has stopped.
-logcat shows some Java functions not found (params missing) in Vendig.apk , though Vneding.apk has same date as other apk,s
Browser, Media and other apps stop working with same error.

I tried to to replace|and or delete the apks with original ones from freescale (Oct 2010 from freescale site, the imx51_bbg), and I am still getting same errors.

Does anyone has the original files from /system/app and the xml's from /system/etc/permissions/
2. The touch sucks, I barely can type, the touch practically unusable and jumps from one place to another. Settings Touch Pad Calibration does not make a
difference, though with a stylus pen is a little better, but with the finger sucks and I don't have bulky fingers. How the one can sell such touch crap. Freescale should provide all the suport, they loosing sales... anyway,

Any ideas how to replace the touch module(s) uilib, EventHub or the driver ?
Any ideas of how to overwrite the firmware ? Kernel, Uboot ...If I am open it do I have access to a serial RS232 ..
Where can I find a recovery.img for this tablet

Thank you
Last edited: