Kindle app on my Galaxy Tablet


Dec 5, 2010
My pre installed Kindle app on my Galaxy Tablet will not allow me to download books from the Amazon store. I have tried reinstalling the app as well and even contacted Amazon support help but so far I have had no luck. Has anyone else experienced this problem with the kindle app on their Galaxy Tablet? Thanks
Last edited:
No. Did u check in your archive? Make sure when u purchase the book that its being sent to your mobile device too

Sent from my DROIDX using Tapatalk
I have the Zenithink operating with android 2.1 and the newest version of Kindle for Android. Any free books download and are readable-no problem. Any purchased books download but trigger an error message. I have re installed, checked to see if the book is on the correct drive, called Amazon-to no avail, and searched the forums. Hopefully a fix, or update, will solve the problem. The tech at Amazon said, "I've never heard of an Android tablet!"

I would love to use the tablet as my primary e-reader.
Hmm my kindle app has worked flawlessly I wish I had some insight for you guys.

Sent from my Samsung Galaxy tablet using Tapatalk
I have exactly the same problem as docmaddison but on the Elonex Etouch Tablet (android 2.1). Free books download but paid one error out but download perfectly to GalaxyS android phone and PC with kindle app. Very frustrating
**** SOLVED****I found out that my Tablet wanted my gmail account instead of my primary one that I use on So I had to add a "default" credit card under my gmail account and wa-la, I fixed it. Thanks for reading!! :)

I have an account I can log in to from my MAC however when I try to log on with the exact same info on my Galaxy Tablet it does not recognize it. When I tried to download a "free" book for my Kindle App it is requesting I register my Tablet Kindle under "your account" in Amazon. So I did, and it asked for the serial number, so I entered it however the Kindle App said that it needed 16 numbers but my tablet only has 11, does anyone know what I need to do? I saw on another post someone else had this same issue and he was able to contact Amazon to get a solution, but he didn't post it! LOL. If anyone an assist, please let me know. I would love to see the "free" books..thanks!
Last edited:
I have the same issue with the Android Kindle app on a ZT-180 tablet. I can download and open drm free books without issue, but when I download purchased books from Amazon with drm, I get an "invalid item" error. I have both an Google account and an Amazon account. When you registered your device with Amazon, did you enter your Google account or Amazon account information? I thought you must enter your Amazon account email and password to register the tablet. I've contacted Amazon, but they have not yet provided a solution.