Looking for ROM update advice - aigoPad M801


Nov 6, 2011
I have scoured the internet the last 3 days searching for a replacement stock ROM or any compatible custom ROM for my Aigo-Pad M801. I'm American but I'm living in China for the next year or so. I don't speak or read Chinese and I've tried going through the Chinese forums for the firmware but couldn't really decipher anything, even with Google translate. And especially not for my tablet.
Specifications Link

I rooted with z4 root and it appeared to work. I installed gapps but couldnt get my market to work out by changing the fingerprint so i wiped cache and media partition to get a clean start again. I DO NOT have clockworkmod. I was not able to get the free version through the chinese market and the only versions i could find from download sites were the ripped off paid version, which i didnt think would work.

Currently when i turn on the tablet it shows the initial bootscreen and never loads the boot animation or any kind of interface. I can access the android stock recovery interface (3e). I read the tablet was for the most part a rebranding of the Ainol Novo so I downloaded a ainol ROM from here . I renamed this update.zip and put it on the root of my SD. When i go to update from the sd card i get this error:
E: failed to verify whole-file signature
E: signature verification failed
Installation aborted

I researched this error but everything I have found assumes i have clockworkmod recovery, which i dont. I have tried, tried, and tried again the option to factory reset but it doesnt seem to solve this stuck of bootscreen problem. The easiest solution seems to be to bypass signature checks or to flash my drive, but I dont know how to mount the internal memory or the sd card to my computer without access to the tablet. I can put things from my computer directly onto the sd card and then insert this into the tablet.

If ANYONE has ANY advice other than to give up please post.
Last edited:


Sep 6, 2012
Hi Lodell, I have the same problem as you. I've got an Aigo M801, which was bought by my sister in-law in China, and it has stopped booting. I tried the update.zip for Gadmei but didn't work, now I cannot even see the logo when booting. I can only access the recovery area, but I can't do anything else. Have you found an answer? Can you help me? Thanks in advance, my regards from Argentina