Mtp device installation issue


Jan 2, 2012

I got a galaxy tab 10.1 for chrissy and it is great. I have a small problem connecting it to my pc however. Each time i try and it begins installing the device i get an error stating it had a problem installing the mtp device with a code 18 in the driver. Now i have made sure i have the latest Kies installed so the drivers should be upto date and i have tried contacting samsung about it but there has been no help there yet. I have also tried different usb ports to eliminate that as the problem. The following is some additional details:

Pc OS : XP sp3
3Gb ram
1.6GHz dual core cpu

In addition I can connect to kies wirelessly though transferring anything large like a movie to the tab that way seems slow and i am hoping that a direct USB connection will be faster.

Thanks in advance for any replies :)

Sent from my GT-P7500 using Android Tablet Forum
Update - got the advice from samsung to hard reset the tab, sounds like a pretty sh!t solution to me, there must be a better way.

Sent from my GT-P7500 using Android Tablet Forum
The mtp drivers are part of the latest installation of Windoze Media Player and nothing to do with samsung.
Install WMP11


In your windows directory

[FONT=&amp]rename C:\WINDOWS\system32\drivers\wudfrd.sys xxx_wudfrd.sys[/FONT]
[FONT=&amp]rename C:\WINDOWS\system32\drivers\wudfpf.sys xxx_wudfpf.sys[/FONT]
[FONT=&amp]rename C:\WINDOWS\system32\wudfhost.exe xxx_wudfhost.exe[/FONT]
[FONT=&amp]rename C:\WINDOWS\system32\wudfsvc.dll xxx_wudfsvc.dll[/FONT]
[FONT=&amp]rename C:\WINDOWS\system32\wudfx.dll xxx_wudfx.dll[/FONT]
[FONT=&amp]rename C:\WINDOWS\system32\wudfplatform.dll xxx_wudfplatform.dll[/FONT]
[FONT=&amp]rename C:\WINDOWS\system32\wudfcoinstaller.dll xxx_wudfcoinstaller.dll[/FONT]

[FONT=&amp]Then run this file UMDF.exe

Thanks pjclark1.

I have the same problem but in W7. I renamed all files, but when I run UMDF.exe, the error is:

"Setup error - Not enough storage is avaible to process this command" - "Installation did not complete".

I tried to unzip the .exe file and replace the .dlls, but this doesn't works...

When I conect my Galaxy Tab the error is on Samsung Mobile MTP Devices driver, code 39.

Any idea?

Thanks again! :)

PD: Sorry if I make some mistakes writing English...

EDITED: Thanks, I solved the problem. It was a Windows Media Player error, like pjclark1 said. I fixed it with Fix WMP utility. :rolleyes:
Last edited:
Locate the *.sys (Where * can be any file) in C:\Windows\system32\drivers. Right click on the file, Properties > Security > Advance and select the 'Owner' tab.

Click on 'Edit' button and mark the local Administrator and click apply.

Close all the pop ups and you will be able to edit the file.

Note: You need to be a local administrator. If the administrator is not present in the Security tab, you can add them once you do the above.