New Flytouch 3 owner

Anyone who used this flytouch 3/Superpad 2, how many hours do you get from a fully charged battery with wifi on?

I really haven't paid too much attention to that yet. I do know that having wi-fi on uses more battery though.
Though for me, I'm not too worried about that stuff yet. I want my SD card to work properly first and get the G-sensor working correctly.
I also need to the wi-fi to be consistent also. It seems that here and there I have trouble connecting unless I go into my router settings and change the channel.
Sometimes I power on the tablet and wi-fi hooks right up and other times it is disconnected for some reason and takes ages to connect again.
Not sure why it disconnects on it's own anyway.
I haven't used anything yet. My tablet is still as I bought it aside from the few apps and games I installed.
So I found a little interesting deal ...
I was tired of taking the Micro-SD card out of the USB adapter so I thought to just leave it in and plug the USB/w card in the tablet.
Well it worked and it worked great. No messing with that tiny little card and trying to insert it in the slot and never mind taking it out. You need tiny fingers.
I noticed one thing though. If you go into MY PAD while it is plugged in, it has an unmount like you do with just using the card alone. But guess what. IT ACTUALLY UNMOUNTS !!

I find it strange that you can use either way to load movies or music or whatever, but only one (USB) will allow you to unmount. This is still an issue I think needs to be addressed though. Not everyone wants a USB dongle sticking out. Problem is, you cant unmount the card by itself for whatever reason.

I'm going to be needing to swap cards from time to time and don't want them getting messed up due to not unmounting or ejecting properly.

I'm not sure if this is a firmware issue for this tablet or not. I haven't seen any other posts about this. There are so many different Flytouch III / SuperPAD II out there.
Like have mentioned. The box mine came in said ANYPC. Now if that even means anything, I don't know. These could all be the same pad only shipped in different boxes due to place of purchase.
Last edited:
This is very interesting. Try a HUGE USB flash drive and try an adaptor in the other slot. Or if you don't have one I will.

Sent from my iPod touch using Tapatalk! Eat that Apple!
I do want to try a straight flash drive. As it is now I technically just have an SD card in a USB adapter. SO it sorta doesn't count.
I'm trying to see if one of my brothers has a large USB flash drive.
Even so, I still want to use just an SD card as it is smaller and out of the way compared to the flash drive sticking out. Problem, as I have mentioned, is there is no "eject" or "unmount" that actually works for the SD card. You can click unmount until your blue in the face and it doesn't actually do it. You get the error "SD card is not inserted in"
That could be an android problem. I'm just not comfortable hotswapping but I guess I'll live lol.

Sent from my iPod touch using Tapatalk! Eat that Apple!
You dont really want to have multiple microSD cards for the external slot as android starts to install stuff onto them eg: titanium backups, game data, app data, etc. When the microsd dissappears (If you swap it with another one), these apps will not work. You are best to load up your movies via a USB key or over the network and copy them direct to your microsd in your external or internal slot.
What do you think is the problem with the SD card not properly unmounting ?
Can firmware fix this ?

As I said, no issues using an USB stick but rather use a card as the USB stick can be in the way and would hate to damage it accidentally by bumping or something.

I am also a new owner of a Flytouch III and was hoping somebody would be able to help. The main thing I want to be able to do with my device is view and do some very basic text editing of simple, but large MS Word documents.

However, I am struggling to find a free app that will allow me to do that. I've tried Olive Office, but it just crashed all the time.

So I moved onto Documents to Go by Dataviz, which I've used before on my Palm Treo and was very happy with. The free version loads my biggest document just fine and seems able to comfortably scroll around it. The problem is, while I'm happy to pay for the full version which allows me to edit, I'm unsure of whether I can get it working because Dataviz don't just give you a license key, which would be ideal, but expect you to download the "Documents To Go Full Version Key" from the Market (which doesn't appear on the Flytouch because it's a paid app) or use the option to send an email to my Android device with the download for the Full Version Key. However, I tried that before when I was first trying to install the free version of Documents to Go and the Flytouch III doesn't seem to capable of handling that type of link.

Basically, I don't want to pay the $15 and find I can't install the thing.

So really, my question is: is there a way of making my device install apps from anywhere other than the Android Market? Or does anyone know of a good document editor that will handle large (over 80,000 words) MS Word documents that is free and/or installable on the Flytouch III?

Thanks in advance.

~ Dave
I have 10" Android 2.3 Flytouch 3 Tablet PC. I can't play online games at kizi website. What shall I do? :(
Last edited:
I think I have had the same problem. Sometimes I can 'hotplug' a USB stick in and the tablet recognises the media and says it is 'preparing it'. Othetimes - nothing.

I also can't get a PC to recognise the tab through a USB-USB connection - I read somewher that it should. Any help anywhere?