Nothing but trouble! White pdn a pain in the ass


Nov 19, 2010
I've tried to update my brand new white PDN with the new Firmware, but all I get for 6 times in a row now are the green droid and the warning sign in the middle of a black screen! I have too many problems to count with this thing, and I regret buying it all the time, but I haven't gotten rid of it because if I can get the countless glitches out, (or softroot it) then it would be exactly what I am looking for in an e-Reader/Tablet!
1. Let's start with the fact that the touchscreen is horrendous, but I can't calibrate it because whenever I try doing the sequence, it says I failed the test and try again, and I try a dozen times in a row before having to reset the device because I can't exit the test! Several times, the device will make the little cross jump around the screen WAY too fast for me to be able to touch it anyway!
2. I went to the Library today to test the WiFi out, and I am happy with the connectivity, and thrilled that I was able to visit my blogging site (livejournal( but yet when I tried to surf the page, the screen in landscape format would be bouncing all around, as if it were trying to get fit and centered in the frame. I got that to stop more or less by adjusting the settings, but then when I tried to use the touch screen on the microscopic links, and tried to type in the update journal box, I had to tap the screen quite harshly many times before it would respond. When I did this with the delete key trying to delete one letter, it would delete a string of words it had just taken me ten minutes to type! When it finally deleted 99% of the entry, I got fed up and turned off the tablet. When I tried to turn it back on, all I got was a white screen, which went away when I reset the device again.
3. I try to load videos onto the device in .mp4 format like it says to, and half of them do not show up on the list, and half of the ones that do are not playing right. When I typed in my yahoo email it wouldn't accept it, saying it was an invalid email!
4. When I try to add files such as videos or music, it only shows a small number of the music files I added and about half of the video (yes, I had a 1GB SD card also in the device, so plenty of room...) I try to play the videos and many of them are not playable correctly, the sound and video are not in sync, but they are on my PC. (ETA: I was able to download the zipped Firmware folder to my PDN and followed the directions to restart, but still the little droid and no progress bar.)

I called PDN Support and they tell me to keep trying the stupid upgrade, and try the SD Card version, but I can't do that because I have no way of reading the SD card outside my PDN device. I have no card reader, the only way I can load the upgrade into the card would be through the tablet. They have no other suggestions for me, like "Sorry, keep trying the upgrade until the end of time, nothing we can do!" BS!
Anyone has any options for me, I'd be happy to hear them!
Last edited:


Nov 25, 2010
I would try one of the earlier upgrades and see if it will go in. If not I would return the unit for a replacement.

Also you might try unplugging it, pulling the battery plug for a few minutes, hook battery back up and reset and try to flash it. Also let it sit, do not get in a hurry, there are some long periods of idle time when it is flashing - screen does nothing for several minutes.

You might also try the open platform upgrade.

On the file business, do the files show up after a reboot? On mine when I transfer files to the sd card I have to reboot to get them to show up - I am using the open platform (Which by the way does not recognize the internal card).