Odd "Installation Unsuccessful" errors (with my fix)


May 16, 2011
Not sure if anyone else had ran into this yet, couldn't find anything with search.

Last weekend I had my a500 all decked out with everything setup and all loaded up with media. That's when I noticed that updates were failing. I couldn't find any logging that told me why it failed. They were failing through both android market and through Amazon appstore. I tried all of the solutions that made sense from what I could find via googling, and nothing worked. At the end, I reset to default and lost everything.

So, I get everything running again and load it up with media, and it happened again. No apps would update nor could I load new ones.

This time, I had kept track of what order I had loaded things and decided to work backwards. First I removed my movies. Then updates started working. What I finally figured out was that 1.2gb of free space, it would not allow me to update apps, at 2.5gb of free space it would. I haven't tested to get the exact number, and I have NO idea what it's seeing that is causing it to stop there.

I will be rooting in the near future and will hope to sort out a bit more of what's going on. I am positive that it's not running out of block devices. The only thing I can figure is that it might have something to do with the way it's allocating the filesystem for the device vs regular storage.


May 11, 2011
There is a hack to change the minimum storage limit, so you wont need that minimum of 1.5GB. Unfortunately, i forgot where that post was. If I run across it, ill post it.


Senior Member
Apr 28, 2011
wouldn't a microsd card make sense?
These are the.
You can move all your movies off of main memory and have much better performance when you need some room for downloads and stuff.