Semi-Bricked MID7036 - Please Help!


Dec 1, 2012
Before I saw this post, I semi-bricked a MID7036-4 by aggressively copying GApps items into the system partition (without any regard as to the files I was overwriting). Since I have two of these units, I carefully rooted the second one, and made a dump of the system directory/partition (as system.tgz). I also dumped the system mtd device into system.img.

The current problem is I have believe I have been unable to fix the system partition.

Here is what doesn't work:
* A regular boot: hangs at COBY logo, and when attached to my Windows 7 PC is seen only as two COBY MID7036 USB Devices (connected by a USB Mass Storage Device). USB debugging appears to be off, as adb devices sees nothing attached to the PC. I believe the Windows drivers are correctly installed, as they work for the other MID7036 when in USB debugging. The silver ANDROID logo never appears anymore on this unit.
* Flashing unsigned or improperly signed zip files for stock recovery. (Even properly signed zips would flash before bricking, but the items that were supposedly installed were missing on the next boot). I have been completely unable to flash an alternative recovery (like CWMR or TWRP) to flash unsigned zip files.
* Overwriting the system partition with fastboot seems to have no effect, even when combined with wiping userdata and cache.
* Any shell access (adb debug). Since I cannot get adb to work on this unit, I have no shell access to the unit.
* Flashing a system restore zip I created and signed (it fails signature verification in recovery).

Here is what works:
* Fastboot (sometimes). I cannot consistently get the unit into the mode compatible with fastboot, but when I can, fastboot will report success in flashing partitions. To get it into this mode, the unit has to off, I have to hold in the Volume + button, connect the unit to my PC via USB cable (with Volume + still held in), and repeatedly press power until COBY appears on the screen. This works sometimes, but is very inconsistent. ADB does not work in this mode.
* Recovery (stock). I can get into the stock recovery by powering on or resetting the unit with either the Volume - or the (hardware) Back button held in. Flashing some signed zips (like the one provided in this thread) reports success, but appears to have no effect upon reboot (even when combined with a data/cache wipe). I have access to zip files on the /nand (internal "SD" partition) or the /sdcard (external SD card) directories. ADB does not work in this mode.

Essentially, I have no ADB access (via regular boot, bootloader, or recovery).

When flashing system.img didn't work, I moved my efforts to creating a flashable zip that would repair the /system directory/mount. I laid out the files from system.tgz, made my updater-script, and copied in an update-binary. I zipped up the resulting heirarchy (using "Store" as the compression type) and used java keytool to sign my zip. I also tried signing with the Google Test Keys. I tried flashing (via recovery and a SDHC card) the unsigned zip, the signed zip (using my keys), and the signed zip (using Google test keys). All failed signature verification.

So I have been unable to repair the unit with ADB (can't get into it), fastboot (flashing system.img appears to have no effect once rebooted), or recovery (my flashable zips fail signature verification).

If anybody wants to see my attempts, I am uploaded them to a folder I am sharing on . Here is the link:

Any help is appreciated.
Last edited:
To whom it may concern:

I gave up on restoring this bricked 7036. Long story short is my wife showed me that the power cord wasn't properly inserted. A few of my attempts at restoration through image flashing had been interrupted by the unit cutting off in the middle of the flash. I believe that this is what bricked it. The online vendor which sold us both units also has brick-and-mortar stores in the area. They were happy to exchange the bricked unit for another working one. They, of course, will return the bricked one to Coby.

I will keep the ROM dumps of the working unit up, as I know that some members of this site were in need of dumps of the 7036. Honestly, I'm pissed at Coby for selling me Android ICS tablets without the Play Store and GApps. To me, that is fraud. It is the same as selling an iPad that couldn't use Apple's app store. The same as selling a Surface tablet without access to the Windows store.

Yes, I am well aware of the Kindle Fire and Nook products. The reason I don't think they are fraudulent is simple. They don't advertise them as Androids. From what I see, they would be perfectly happy with consumers not even knowing that they were built on Android.

Because I resent being misled, I don't plan on purchasing a Coby product ever again. Caveat emptor.

It honestly never occurred to me that anyone would market a tablet with Android 4.0 Ice Cream Sandwich, with no Google Apps and no Google Play Store.
I understand your frustration given that every device seems to have the Play Store. It wasn't a smart choice on Coby's part to not have the Play Store and I don't blame you. However manufacturers are not obligated to use the Play Store if they use Android. The Play Store is governed under a separate agreement from the Android OS, which is something the average consumer would not know.

There is no fraud here.