Testing GPS

Jan 15, 2012
I read somewhere that the GPS did not work on SOME units!
One of the main reasons I bought this Tablet was for the GPS ..
Is there a way to tell if mine is working? Does this tell me if it is working?
I first installed my Nav software Locus Pro, OruxMaps..I cached the area i wanted and set the program to locate the cached files. drove around my area and it did not follow me with GPS enabled (settings/Location & Security/Use GPS Satellites)
I came home and installed GPS Status and GPS Test apps...They both show satellites !
Do you think that being those 2 app show satellite`s that my GPS function is working OK and it is probably some Nav software setting i need to mess with or could it be the GPS not working even though the GPS test is showing sats?
check and make sure that you are running those apps with WiFi off. You want to make sure you are getting actual GPS results, not aGPS
Got it worked out thanks..The GPS app finally found the Sats and I am good to go..Used it offline yesterday and it worked ..